Or call our technical support: +31852080825

Available Monday through Friday from 7AM to 3:30PM CET
Please create a ticket before calling and keep the ticket number at hand.
At the moment we are only offering support in English, so we kindly ask you to address your issue in English.
Start a new topic

Extruder Temp bouncing down 10 degrees during printing

Hello folks,

from a couple of month ago my printer (creatr dual extruder) has start randomly to not hold the temp of the extruder (both).

As you can see in the image below the temp fall down by 10/15°C, and the extruder  in that moment stops extruding, causing what you can see in the other image.

Already tried: 

-check all the wire OK move the wire all long during printing NOTHING HAPPEN switched the extruder NOTHING CHANGE

-refresh the firmware as suggested by the support but still no improvment

-PID tuning better alignment of temp reached and desired but still the falling down happen

Has someone experienced the same issue? or anyone have a suggest on how try to find out where the problem could be?

Thanks a lot for any suggestion, this is going me mad.


Hi Gilles and thanks for you answer,

do you mean that a 2% difference in the filament diameter could give that kind of temperature bounce( first Img )? 


Perhaps it is a trouble with the slicer. Try another slicer or change some parameters. I use Simplify 3d and I had this kind of trouble then I try to setup precisely the filament diameter (as I do with Slice3r) but for a not clear reason I get best result with the same Filament diameter (1.75) for all roll of filament and I modify only "extrusion multiplier"  (in the extruder section - left or right depending). I compute the extrusion multiplier: 1.75 / real_diameter (get with a caliper for each roll). This give better result. I suspect that there is some mistake in simplify 3D when calculating the amount of filament when using the filament diameter.


I tried the PID Autotuning by sending the command manually, this improve the stabilitation of the temp, but the fault in the middle of the printing still happen. Still working on a solution.......

it is the PID. check here: http://creatrhs.lpfrg.com/support/solutions/folders/1000172527

I had this too, you need to upgrade the PIC firmware of the printer( see downloads here somewhere) after that it works great. also do all other firmware upgrades.( new menus)

Login or Signup to post a comment